List of Open Source Software which can be built on Fugaku

Spack logo
Spack will be used to manage open source software packages on Fugaku. Fugaku users can easily use pre-installed packages and built packages based on Spack recipes. The following list shows the results of building/compiling packages for aarch64 according to the Spack recipes. Note that the results in this list do not guarantee that each package will work properly. On the other hand, Fujitsu will provide the following packages compiled with Fujitsu compiler on Fugaku as "external" packages, of which Spack can be aware.
  • OpenJDK 11
  • Ruby 2.6.5 or later
  • Python2 2.7.15
  • Python3 3.6.8
  • Numpy 1.14.3
  • SciPy 1.0.0
  • Eclipse IDE 2019-09 R Packages
Please contact us from email:

Build success rate per compiler


Last Modified: 4/8/24, 2:58 AM GMT
Spack Version: 1/18/24, 1:14 AM GMT
Click each result for further infomation.
Package Version Fujitsu Compiler GCC
evemu 2.7.0 YES
everytrace 0.2.2 Dependency Error
everytrace-example develop Dependency Error
evieext 1.1.1 YES
evtgen 02.02.00 YES
exa 0.10.1 Dependency Error
exabayes 1.5.1 Dependency Error
exaca 1.2.0 YES
exago 1.6.0 Dependency Error
examinimd 1.0 Dependency Error
examl 3.0.22 Skipped
exampm master Dependency Error
exasp2 1.0 Dependency Error
exawind master Dependency Error
exaworks 0.1.0 Dependency Error
exciting oxygen
exempi 2.6.1 YES
exiv2 0.27.6 YES
exmcutils 0.6.0 YES
exodusii 2021-04-05 YES
exonerate 2.4.0 Dependency Error
exonerate-gff3 2.3.0 Dependency Error
expat 2.5.0 YES
expect 5.45.4 YES
express 1.5.3 YES
extrae 4.0.6 YES
exuberant-ctags 5.8 YES
eztrace 2.1 Dependency Error
f2c master YES
f3d 2.0.0 Dependency Error
f77-zmq 4.3.2 YES
f90cache 0.99c YES
fabtests 1.9.1 YES
faircmakemodules 1.0.0 YES
fairlogger 1.11.1 YES
fairmq 1.7.0
faiss 1.7.4 YES
fakechroot 2.20.1
fakexrandr master YES
falco 1.2.1 YES
falcon 2017-05-30 Dependency Error
fann 2.2.0 YES
faodel 1.2108.1 YES
fargparse 1.5.0 Dependency Error
fasd 1.0.1 YES
fast-global-file-status 1.1.1 YES
fasta 36.3.8h_2020-05-04 Dependency Error
fastani 1.34 Dependency Error
fastdb 3.75 YES
fastdfs 6.05 Dependency Error
fastjar 0.98 YES
fastjet 3.4.1 Dependency Error
fastjson 1.2.68 YES
fastmath latest Dependency Error
fastme 2.1.5.1 YES
fastp 0.23.4 Dependency Error
fastphase 2016-03-30 YES
fastq-screen 0.15.3 Dependency Error
fastqc 0.12.1 YES
fastqvalidator 2017-01-10 YES
fasttext 0.9.2 Dependency Error
fasttransforms 0.6.2 Dependency Error
fasttree 2.1.11 YES
fastx-toolkit 0.0.14 YES
faust 2.54.9 YES
fbgemm 2021-05-10 Dependency Error
fca 2.5.2431 Dependency Error
fcgi 2.4.2 YES
fckit 0.11.0 Dependency Error
fd 8.7.0 Dependency Error
fdb 5.11.23 Dependency Error
fds 6.8.0 Dependency Error
fdupes 2.2.1 YES
feh 3.10 Dependency Error
fenics 2019.1.0.post0 Dependency Error
fenics-basix 0.7.0 Dependency Error
fenics-dolfinx 0.6.0 Dependency Error
fenics-ufcx 0.6.0 YES
feq-parse 2.0.3 YES
fermi 1.1 Dependency Error
fermikit 2017-11-7 Dependency Error
fermisciencetools 11r5p3 YES
ferret 7.6.0 Dependency Error
feynhiggs 2.18.1 Dependency Error
ffb 8.1 Dependency Error
ffmpeg 6.0 YES
ffr 3.1.004 Dependency Error
ffsb 5.2.1 YES
ffte 7.0 YES
fftw 3.3.10 YES
fftx 1.1.3 YES
fgsl 1.5.0 YES
fiat 1.2.0 Dependency Error
fides 1.2.0 Dependency Error
figcone 2.4.9 Dependency Error
figlet 2.2.5 YES
figtree 1.4.4 YES
file 5.44 YES
filebench 1.4.9.1 Dependency Error
filo main Dependency Error
filtlong 0.2.1 YES
fimpute 2014-01 YES
findbugs 3.0.1 YES
findutils 4.9.0 Dependency Error
fio 3.34 YES
fipscheck 7.0.0.398 YES
fish 3.6.1 YES
fixesproto 5.0 YES
fj None Dependency Error
fjcontrib 1.052 Dependency Error
fl 0.79.47 Dependency Error
flac 1.4.2 YES
flamemaster 4.3.1 Dependency Error
flann 1.9.2 YES
flap master Dependency Error
flash 1.2.11 YES
flashdimmsim master YES
flatbuffers 2.0.6 YES
flatcc 0.5.3 YES
flcl 0.99.0 Dependency Error
flecsale develop Dependency Error
flecsi 2.2.1 Dependency Error
flecsph master Dependency Error
fleur 5.1 Dependency Error
flex 2.6.3 YES
flexi master Dependency Error
flexiblas 3.3.0 YES
flibcpp 1.0.2 YES
flink 1.9.1 YES
flint 2.5.2 Dependency Error
flit 2.1.0 YES
fltk 1.3.7 YES
flume 1.9.0 YES
flux-core 0.55.0 YES
flux-pmix 0.4.0 Dependency Error
flux-sched 0.29.0 Dependency Error
flux-security 0.10.0 YES
fluxbox 1.3.7 YES
fms 2023.02 Dependency Error
fmt 10.1.1 YES
foam-extend 4.1 Dependency Error
folly 2021.05.24.00 YES
font-util 1.4.0 Dependency Error
fontcacheproto 0.1.3 YES
fontconfig 2.14.2 Dependency Error
fontsproto 2.1.3 YES
fonttosfnt 1.2.2 YES
foonathan-memory 0.7-3 YES
form 4.3.1 YES
formetis 0.0.2 YES
fortran None Skipped
fortrilinos 2.3.0 YES
fossil 2.18 YES
foundationdb 6.3.4 Dependency Error
fox 1.6.57 Dependency Error
fp16 2020-05-14 YES
fpart 1.5.1 YES
fpc 3.0.2 YES
fpchecker 0.4.0 YES
fping 5.1 YES
fplll 5.4.4 YES
fplo 22.00-62 Dependency Error
fpm 0.9.0 Dependency Error
fpocket 4.1 Dependency Error
fpzip 1.3.0 YES
fq 0.10.0 Dependency Error
fqtrim 0.9.7 YES
fr-hit 0.7.1-2013-02-20 Dependency Error
fraggenescan 1.31 YES
freebayes 1.3.6 Dependency Error
freecad 0.20.2 Dependency Error
freefem 4.10 YES
freeglut 3.2.2 Dependency Error
freeimage 3.18.0 Dependency Error
freeipmi 1.6.9 Dependency Error
freesasa 2.1.2 YES
freesurfer 7.4.1 Dependency Error
freetype 2.11.1 Dependency Error
freexl 1.0.5 YES
fribidi 1.0.12 YES
frontier-client 2_9_1 Dependency Error
frontistr 5.3 YES
fseq 1.84 YES
fsl 6.0.5 Dependency Error
fslsfonts 1.0.6 YES
fstobdf 1.0.7 YES
fstrack 0.5.3.092918 Dependency Error
ftgl 2.4.0 Dependency Error
ftjam 2.5.2 YES
ftk 0.0.7.1 YES
ftobjectlibrary main Dependency Error
ftxui 4.1.1 YES
fujitsu-fftw 1.1.0 YES
fujitsu-frontistr 5.2 Dependency Error
fujitsu-mpi None Dependency Error
fujitsu-ssl2 None Dependency Error
fullock 1.0.50 YES
funhpc 1.3.0 Dependency Error
funwave 3.2 Dependency Error
fuse-overlayfs 1.10 YES

Page 5 of 38, showing 200 record(s) out of 7,469 total