List of Open Source Software which can be built on Fugaku

Spack logo
Spack will be used to manage open source software packages on Fugaku. Fugaku users can easily use pre-installed packages and built packages based on Spack recipes. The following list shows the results of building/compiling packages for aarch64 according to the Spack recipes. Note that the results in this list do not guarantee that each package will work properly. On the other hand, Fujitsu will provide the following packages compiled with Fujitsu compiler on Fugaku as "external" packages, of which Spack can be aware.
  • OpenJDK 11
  • Ruby 2.6.5 or later
  • Python2 2.7.15
  • Python3 3.6.8
  • Numpy 1.14.3
  • SciPy 1.0.0
  • Eclipse IDE 2019-09 R Packages
Please contact us from email:

Build success rate per compiler


Last Modified: 4/8/24, 2:58 AM GMT
Spack Version: 1/18/24, 1:14 AM GMT
Click each result for further infomation.
Package Version Fujitsu Compiler GCC
zziplib 0.13.72 Dependency Error
zstr 1.0.7 Dependency Error
zstd 1.5.5 Dependency Error
zsh 5.8 Dependency Error
zpares 0.9.6a Dependency Error
zopfli 1.0.3 Dependency Error
zookeeper-benchmark master Dependency Error
zookeeper 3.4.11 Dependency Error
zoltan 3.901 Dependency Error
zlib-ng 2.1.4 Dependency Error
zlib 1.3 Dependency Error
zipkin 2.21.5 Dependency Error
zip 3.0 Dependency Error
zig 0.11.0 Dependency Error
zfs 0.8.3 Dependency Error
zfp 1.0.0 Dependency Error
zabbix 5.0.3 Dependency Error
z3 4.11.2 Dependency Error
z-checker 0.9.0 Dependency Error
yorick 2.2.04 Dependency Error
yoda 1.9.8 Dependency Error
ycsb 0.17.0 Dependency Error
ycruncher 0.7.10.9513 Dependency Error
yasm 1.3.0 Dependency Error
yarn 1.22.4 Dependency Error
yara 3.9.0 Dependency Error
yaml-cpp 0.7.0 Dependency Error
yambo 5.1.1 Dependency Error
yaksa 0.3 Dependency Error
yajl 2.1.0 Dependency Error
yafyaml 1.1.0 Dependency Error
yade 2023.02a Dependency Error
xz 5.4.1 Dependency Error
xyce 7.7.0 Dependency Error
xxhash 0.8.1 Dependency Error
xxdiff 2023-01-10 Dependency Error
xxd-standalone 8.2.1201 Dependency Error
xwud 1.0.6 Dependency Error
xwininfo 1.1.5 Dependency Error
xwidgets 0.25.0 Dependency Error
xwd 1.0.8 Dependency Error
xvinfo 1.1.5 Dependency Error
xvidtune 1.0.4 Dependency Error
xv 4.2.0 Dependency Error
xts 0.99.1 Dependency Error
xtrap 1.0.3 Dependency Error
xtrans 1.4.0 Dependency Error
xtl 0.7.4 Dependency Error
xterm 353 Dependency Error
xtensor-python 0.23.1 Dependency Error
xtensor-blas 0.20.0 Dependency Error
xtensor 0.24.1 Dependency Error
xtcdata 3.3.37 Dependency Error
xtb 6.6.0 Dependency Error
xstdcmap 1.0.5 Dependency Error
xsm 1.0.5 Dependency Error
xsimd 8.1.0 Dependency Error
xsetroot 1.1.3 Dependency Error
xsetpointer 1.0.1 Dependency Error
xsetmode 1.0.0 Dependency Error
xset 1.2.5 Dependency Error
xsdk-examples 0.4.0 Dependency Error
xsdk 0.8.0 Dependency Error
xsd 4.0.0 Dependency Error
xscope 1.4.3 Dependency Error
xsbench 20 Dependency Error
xrx 1.0.4 Dependency Error
xrootd 5.6.1 Dependency Error
xrefresh 1.0.7 Dependency Error
xrdcl-record 5.4.2 Dependency Error
xrdb 1.2.1 Dependency Error
xrandr 1.5.0 Dependency Error
xqilla 2.3.3 Dependency Error
xproxymanagementprotocol 1.0.3 Dependency Error
xproto 7.0.31 Dependency Error
xproperty 0.11.0 Dependency Error
xprop 1.2.6 Dependency Error
xprehashprinterlist 1.0.1 Dependency Error
xpr 1.1.0 Dependency Error
xpmem 2.6.5-36 Dependency Error
xplsprinters 1.0.1 Dependency Error
xplor-nih 2.45 Dependency Error
xphelloworld 1.0.1 Dependency Error
xorg-sgml-doctools 1.12 Dependency Error
xorg-server 1.18.99.901 Dependency Error
xorg-gtest 0.7.1 Dependency Error
xorg-docs 1.7.2 Dependency Error
xorg-cf-files 1.0.6 Dependency Error
xnnpack 2022-02-16 Dependency Error
xmore 1.0.3 Dependency Error
xmodmap 1.0.11 Dependency Error
xmlto 0.0.28 Dependency Error
xmlrpc-c 1.51.06 Dependency Error
xmlf90 1.5.4 Dependency Error
xmh 1.0.4 Dependency Error
xmessage 1.0.6 Dependency Error
xman 1.1.5 Dependency Error
xmag 1.0.7 Dependency Error
xlsfonts 1.0.7 Dependency Error
xlsclients 1.1.5 Dependency Error
xlsatoms 1.1.4 Dependency Error
xlogo 1.0.6 Dependency Error
xload 1.1.4 Dependency Error
xlf None Skipped
xlc None Skipped
xkill 1.0.6 Dependency Error
xkeyboard-config 2.34 Dependency Error
xkbutils 1.0.5 Dependency Error
xkbprint 1.0.6 Dependency Error
xkbevd 1.1.5 Dependency Error
xkbdata 1.0.1 Dependency Error
xkbcomp 1.4.4 Dependency Error
xios 2.5 Dependency Error
xinput 1.6.3 Dependency Error
xinit 1.4.2 Dependency Error
xineramaproto 1.2.1 Dependency Error
xhost 1.0.9 Dependency Error
xhmm 20160104 Dependency Error
xgc 1.0.6 Dependency Error
xgboost 1.6.2 Dependency Error
xgamma 1.0.7 Dependency Error
xfwp 1.0.3 Dependency Error
xfsprogs 5.11.0 Dependency Error
xfsinfo 1.0.7 Dependency Error
xfsdump 3.1.6 Dependency Error
xfs 1.2.1 Dependency Error
xforms 1.2.4 Dependency Error
xfontsel 1.1.0 Dependency Error
xfindproxy 1.0.4 Dependency Error
xfd 1.1.4 Dependency Error
xf86vidmodeproto 2.3.1 Dependency Error
xf86rushproto 1.1.2 Dependency Error
xf86miscproto 0.9.3 Dependency Error
xf86driproto 2.1.1 Dependency Error
xf86dgaproto 2.1 Dependency Error
xf86dga 1.0.3 Dependency Error
xf86bigfontproto 1.2.0 Dependency Error
xeyes 1.2.0 Dependency Error
xextproto 7.3.0 Dependency Error
xev 1.2.5 Dependency Error
xeus 1.0.4 Dependency Error
xerces-c 3.2.4 Dependency Error
xedit 1.2.3 Dependency Error
xdriinfo 1.0.7 Dependency Error
xdpyinfo 1.3.3 Dependency Error
xdotool 3.20211022.1 Dependency Error
xdmf3 2019-01-14 Dependency Error
xdm 1.1.14 Dependency Error
xditview 1.0.6 Dependency Error
xdelta 3.1.0 Dependency Error
xdbedizzy 1.1.0 Dependency Error
xcursorgen 1.0.8 Dependency Error
xcursor-themes 1.0.4 Dependency Error
xconsole 1.0.8 Dependency Error
xcompmgr 1.1.9 Dependency Error
xcmsdb 1.0.6 Dependency Error
xcmiscproto 1.2.2 Dependency Error
xclock 1.1.1 Dependency Error
xclipboard 1.1.4 Dependency Error
xclip 0.13 Dependency Error
xcfun 2.1.1 Dependency Error
xcb-util-xrm 1.2 Dependency Error
xcb-util-wm 0.4.2 Dependency Error
xcb-util-renderutil 0.3.10 Dependency Error
xcb-util-keysyms 0.4.1 Dependency Error
xcb-util-image 0.4.1 Dependency Error
xcb-util-errors 1.0.1 Dependency Error
xcb-util-cursor 0.1.4 Dependency Error
xcb-util 0.4.1 Dependency Error
xcb-proto 1.15.2 Dependency Error
xcb-demo 0.1 Dependency Error
xcalc 1.1.1 Dependency Error
xbraid 3.0.0 Dependency Error
xbitmaps 1.1.1 Dependency Error
xbiff 1.0.4 Dependency Error
xbacklight 1.2.3 Dependency Error
xauth 1.1.2 Dependency Error
xapian-core 1.4.19 Dependency Error
xalan-c 1.12 Dependency Error
xabclib 1.03 Dependency Error
x264 20210613 Dependency Error
x11perf 1.6.1 Dependency Error
wxwidgets 3.2.2.1 Dependency Error
wxpropgrid 1.4.15 Dependency Error
wxparaver 4.9.2 Dependency Error
wtdbg2 2.3 Dependency Error
wt 3.3.7 Dependency Error
wsmancli 2.6.2 Dependency Error
wrk 4.1.0 Dependency Error
wrf-io 1.2.0 Dependency Error
wrf 4.5.1 Dependency Error
wps 4.5 Dependency Error
wordnet 3.0 Dependency Error
wonton 1.3.2 Dependency Error
wise2 2.4.1 Dependency Error
wireshark 3.2.1 Dependency Error
wiredtiger 10.0.0 Dependency Error
windowswmproto 1.0.4 Dependency Error
winbison 2.5.25 Dependency Error
win-wdk 10.0.19041 Dependency Error

Page 1 of 38, showing 200 record(s) out of 7,469 total