List of Open Source Software which can be built on Fugaku

Spack logo
Spack will be used to manage open source software packages on Fugaku. Fugaku users can easily use pre-installed packages and built packages based on Spack recipes. The following list shows the results of building/compiling packages for aarch64 according to the Spack recipes. Note that the results in this list do not guarantee that each package will work properly. On the other hand, Fujitsu will provide the following packages compiled with Fujitsu compiler on Fugaku as "external" packages, of which Spack can be aware.
  • OpenJDK 11
  • Ruby 2.6.5 or later
  • Python2 2.7.15
  • Python3 3.6.8
  • Numpy 1.14.3
  • SciPy 1.0.0
  • Eclipse IDE 2019-09 R Packages
Please contact us from email:

Build success rate per compiler


Last Modified: 4/8/24, 2:58 AM GMT
Spack Version: 1/18/24, 1:14 AM GMT
Click each result for further infomation.
Package Version Fujitsu Compiler GCC
cgdb master Dependency Error
cgdcbxd 1.0.2 Dependency Error
cget 0.2.0 YES
cgl 0.60.7 YES
cgm 16.0 YES
cgns 4.4.0 YES
chaco 2020-07-16 YES
chai 2022.03.0 YES
chameleon 1.2.0 Dependency Error
changa 3.4 Dependency Error
channelflow master YES
chaparral 2020-08-28 YES
chapel 1.24.1 YES
chaplin 1.2 YES
charliecloud 0.35 YES
charmpp 7.0.0 Dependency Error
chatterbug 1.0 Dependency Error
check 0.15.2 YES
chemfiles 0.10.4 YES
chexmix 0.52 Dependency Error
chgcentre 1.6 Dependency Error
chlorop 1.1 Dependency Error
chombo 3.2 Dependency Error
chrony 3.5.1 YES
chrpath 0.16 YES
cinch 1.0 YES
circe2 3.1.2.1 YES
circos 0.69-9 Dependency Error
cistem 1.0.0-beta Skipped
citcoms 3.3.1 YES
cityhash 2013-07-31 YES
cjson 1.7.15 YES
ck 0.6.2 Dependency Error
clamav 0.101.2 Dependency Error
clamr master Dependency Error
clapack 3.2.1 Dependency Error
clara 1.1.5 YES
claw 2.0.3 Dependency Error
clblast 1.5.2 Dependency Error
cleaveland4 4.5 Dependency Error
cleverleaf develop YES
clfft 2.12.2 Dependency Error
clhep 2.4.6.4 YES
cli11 2.3.2 YES
clinfo 3.0.21.02.21 Dependency Error
clingo 5.6.2 Dependency Error
clingo-bootstrap 5.6.2 Dependency Error
cln 1.3.6 Dependency Error
cloc 1.96.1 YES
cloog 0.18.4 YES
cloverleaf 1.1 YES
cloverleaf-ref 1.3 Dependency Error
cloverleaf3d 1.0 YES
clp 1.17.7 YES
clustal-omega 1.2.4 YES
clustalw 2.1 YES
cmake 3.27.7 YES
cmaq 5.3.1 YES
cmark 0.29.0 YES
cmdlime 2.5.0 YES
cmdstan 2.30.1 Dependency Error
cminpack 1.3.6 YES
cmocka 1.1.7 YES
cmockery 0.1.2 YES
cmor 3.7.2 YES
cni-plugins 1.3.0 YES
cnmem git Dependency Error
cnpy master YES
cntk 2.0 Dependency Error
cntk1bitsgd c8b77d YES
cnvnator 0.3.3 Dependency Error
codar-cheetah 1.1.0 YES
code-server 4.12.0 YES
codec2 1.1.0 YES
codecov None Dependency Error
codes 1.1.0 Dependency Error
coevp develop Dependency Error
cohmm develop YES
coin3d 4.0.0 Dependency Error
coinhsl 2015.06.23 Dependency Error
coinutils 2.11.9 YES
collectd 5.12.0 YES
collier 1.2.8 YES
colm 0.12.0 YES
colordiff 1.0.21 YES
comd 1.1 YES
comgr 5.6.1 Dependency Error
commons-lang 2.6 YES
commons-lang3 3.12.0 YES
commons-logging 1.2 YES
compadre 1.5.0 YES
compiz 0.7.8 Dependency Error
composable-kernel 5.6.1 Dependency Error
compose 2.17 YES
compositeproto 0.4.2 YES
conda4aarch64 1.0.0 YES
conduit 0.8.8 YES
conmon 2.1.7 Dependency Error
connect-proxy 1.105 YES
conquest 1.2 Dependency Error
conserver 8.2.7 YES
console-bridge 1.0.2 YES
constype 1.0.5 Dependency Error
consul 1.15.3 YES
converge 2.4.10 Dependency Error
cool 3.3.10
coordgen 3.0.2
coral 3.3.10
corenlp 4.0.0 YES
coreutils 9.3 YES
corset 1.09 YES
cosbench 0.4.2 YES
cosign 1.3.1
cosma 2.6.6 Dependency Error
cosmoflow-benchmark master Dependency Error
cosmomc 2016.11 Dependency Error
cosp2 master YES
costa 2.2.2 YES
cotter 20190205 Dependency Error
cowsay 3.04 YES
cp2k 2023.2 Dependency Error
cpat 3.0.4 Dependency Error
cpio 2.14 YES
cplex 12.10.0 Dependency Error
cpmd 4.3 YES
cpp-argparse 2.9 YES
cpp-httplib 0.12.5 YES
cpp-logger 0.0.1 YES
cpp-termcolor 2.0.0 YES
cppad 20170114 Dependency Error
cppcheck 2.9 Dependency Error
cppcodec 0.2 Dependency Error
cppcoro 2021-01-13 Dependency Error
cppgsl 4.0.0 YES
cpprestsdk 2.10.16 Dependency Error
cppunit 1.14.0 YES
cppzmq 4.9.0 YES
cpr 1.10.4 Dependency Error
cpu-features 0.7.0 YES
cpuinfo 2022-08-19 YES
cqrlib 1.1.2 Dependency Error
cquery 2018-08-23 Dependency Error
cracklib 2.9.9 YES
cradl master Dependency Error
cram 1.0.1 Dependency Error
cray-fftw 3.3.8.12 Skipped
cray-libsci 21.08.1.2 Skipped
cray-mpich 8.1.7 Skipped
cray-mvapich2 8.1.0 Dependency Error
cray-pmi 5.0.17 Dependency Error
creduce 2.10.0 Dependency Error
crmc 2.0.1 Dependency Error
cromwell 85 YES
cromwell-womtool 44 YES
cronie 1.6.1 YES
crosstool-ng 1.26.0 Dependency Error
crtm 2.4.0 YES
crtm-fix 2.4.0_emc YES
crunch master Dependency Error
cryptopp 8.7.0 YES
cryptsetup 2.3.5 YES
csa-c master YES
cscope 15.9 Dependency Error
csdp 6.1.1 Dependency Error
ctffind 4.1.14 Dependency Error
ctpl 0.3 Dependency Error
ctre 2.8.4 YES
cub 2.1.0 YES
cuba 4.2.2 YES
cube 4.8 Dependency Error
cube-blade 0.2 Dependency Error
cubelib 4.8.2 YES
cubew 4.8.2 YES
cubist 2.07 YES
cuda 11.8.0 Skipped
cuda-memtest master Skipped
cudnn 8.7.0.84-11.8 Skipped
cufflinks 2.2.1 YES
cunit 2.1-3
cupla 0.3.0 YES
cups 2.3.3 YES
curl 8.4.0 Dependency Error
cusz 0.3.1 Dependency Error
cutensor 1.5.0.3 YES
cutlang 2.12.10 Dependency Error
cutlass 2.9.1 Dependency Error
cvector 1.0.3 Dependency Error
cvise 2.7.0 Dependency Error
cvs 1.12.13 YES
cxx None Skipped
cxxopts 3.1.1 YES
cxxtest 4.4 YES
cyrus-sasl 2.1.28 YES
czmq 4.1.1 YES
daemonize 1.7.8 YES
dakota 6.18 Dependency Error
daligner 1.0 YES
dalton 2020.0 Dependency Error
damageproto 1.2.1 YES
damaris 1.9.2 YES

Page 3 of 38, showing 200 record(s) out of 7,469 total