List of Open Source Software which can be built on Fugaku

Spack logo
Spack will be used to manage open source software packages on Fugaku. Fugaku users can easily use pre-installed packages and built packages based on Spack recipes. The following list shows the results of building/compiling packages for aarch64 according to the Spack recipes. Note that the results in this list do not guarantee that each package will work properly. On the other hand, Fujitsu will provide the following packages compiled with Fujitsu compiler on Fugaku as "external" packages, of which Spack can be aware.
  • OpenJDK 11
  • Ruby 2.6.5 or later
  • Python2 2.7.15
  • Python3 3.6.8
  • Numpy 1.14.3
  • SciPy 1.0.0
  • Eclipse IDE 2019-09 R Packages
Please contact us from email:

Build success rate per compiler


Last Modified: 4/8/24, 2:58 AM GMT
Spack Version: 1/18/24, 1:14 AM GMT
Click each result for further infomation.
Package Version Fujitsu Compiler GCC
gsl-lite 0.41.0 YES
gslib 1.0.7 YES
gsoap 2.8.127 YES
gtk-doc 1.33.2 YES
gtkmm 2.19.7
gtkorvo-atl 2.2 YES
gtkorvo-cercs-env 1.0 YES
gtkorvo-dill 2.4 YES
gtkorvo-enet 1.3.14 YES
gtkplus 3.24.29
gtksourceview 4.2.0
gts 121130
guacamole-client 1.2.0 YES
guacamole-server 1.1.0 Dependency Error
guidance 2.02 Dependency Error
guile 2.2.6 Dependency Error
gunrock 1.2 Dependency Error
gurobi 10.0.0 Dependency Error
gxsview 2023.05.29 Dependency Error
gzip 1.12 YES
h2database 1.4.200 YES
h5bench 1.4 YES
h5cpp 1.10.4-6 YES
h5hut 2.0.0rc3 Dependency Error
h5part 1.6.6 Dependency Error
h5utils 1.13.1 YES
h5z-zfp 1.1.1 Dependency Error
haccabana master YES
hacckernels develop YES
hackrf-host 2018.01.1 YES
hadoop 3.3.2 YES
hadoop-xrootd 1.0.7 Dependency Error
hal 2.1 Dependency Error
half 2.1.0 YES
halide 15.0.0 Dependency Error
hama 0.7.1 YES
hapcut2 2017-07-10 Dependency Error
hapdip 2018.02.20 YES
haploview 4.1 YES
haproxy 2.1.1 YES
hardlink 0.1.1 YES
harfbuzz 7.3.0 Dependency Error
harminv 1.4.2 YES
hashcat 6.2.6 YES
haveged 1.9.13 Dependency Error
hazelcast 5.2.3 Dependency Error
hbase 2.5.4 YES
hbm-dramsim2 1.0.0 YES
hc 1.0.7 YES
hcoll 4.8.3221 Dependency Error
hdf 4.2.15 Dependency Error
hdf-eos2 2.20v1.00 Dependency Error
hdf-eos5 5.1.16 Dependency Error
hdf5 1.14.3 YES
hdf5-blosc master YES
hdf5-vfd-gds 1.0.2 Dependency Error
hdf5-vol-async 1.7 YES
hdf5-vol-cache v1.1 YES
hdf5-vol-daos 1.2.0 Dependency Error
hdf5-vol-external-passthrough 1.1 YES
hdf5-vol-log 1.4.0 YES
hdfview 3.3.0 YES
healpix-cxx 3.50.0 Dependency Error
heaptrack 1.3.0 YES
heasoft 6.30 Dependency Error
heffte 2.4.0 YES
helib 2.2.2 Dependency Error
helics 3.4.0 Dependency Error
help2man 1.49.3 YES
henson master Skipped
hepmc 2.06.11 YES
hepmc3 3.2.6 YES
hepmcanalysis 3.4.13 Dependency Error
heppdt 2.06.01 YES
heputils 1.3.2 YES
hercules 10.7.2 Dependency Error
hermes 0.9.0-beta Dependency Error
herwig3 7.2.3 Dependency Error
herwigpp 2.7.1 Dependency Error
hevea 2.35 YES
hh-suite 3.3.0 Dependency Error
hibench 7.1 Dependency Error
hicolor-icon-theme 0.17 YES
hicops release Dependency Error
highfive 2.8.0 YES
highway 1.0.7 Dependency Error
highwayhash dfcb97 Dependency Error
hiop 1.0.1 YES
hip 5.6.1 Skipped
hip-examples 5.4.3 Dependency Error
hip-rocclr 5.6.1 Dependency Error
hipace 23.07 Dependency Error
hipblas 5.6.1
hipcub 5.6.1
hipfft 5.6.1
hipfort 5.6.1 Skipped
hipify-clang 5.6.1
hiprand 5.6.1 Dependency Error
hipsolver 5.6.1 Dependency Error
hipsparse 5.6.1 Dependency Error
hipsycl 0.9.4 YES
hiptt master Dependency Error
hiredis 1.1.0 YES
hisat2 2.2.1 Skipped
hisea 2017.12.26 Dependency Error
hive 3.1.2 YES
hivex 1.3.23 Dependency Error
hmmer 3.4 Skipped
hohqmesh 1.3.0 Dependency Error
homer 4.11.1 YES
hoomd-blue 2.2.2 Dependency Error
hoppet 1.2.0 YES
hotspot 6.0 YES
hpcc 1.5.0 YES
hpccg 1.0 YES
hpcg 3.1 Dependency Error
hpctoolkit 2023.08.1 Dependency Error
hpcviewer 2023.07 YES
hpcx-mpi None Dependency Error
hpddm 2.2.3 Dependency Error
hpgmg 0.4 YES
hping master Dependency Error
hpl 2.3 YES
hpx 1.9.1 Skipped
hpx-kokkos 0.4.0 Dependency Error
hpx5 4.1.0 Dependency Error
hsa-rocr-dev 5.6.1 Dependency Error
hsakmt 1.0.0 YES
hsakmt-roct 5.6.1 Dependency Error
hsf-cmaketools 1.8 YES
hssp 3.1.5 YES
hstr 1.22 Dependency Error
hto4l 2.02 Dependency Error
htop 3.2.2 YES
htslib 1.17 Dependency Error
http-get 2018-05-23 YES
http-load 2016-03-09 YES
http-parser 2.9.4 YES
http-ping 2016-03-09 YES
http-post 2018-05-18 YES
httpd 2.4.55 YES
httperf master YES
httpie 3.2.1 YES
httping 2.5 YES
httpress 1.1.0 Dependency Error
hub 2.2.2 Dependency Error
hudi 0.5.3 Dependency Error
hugo 0.118.2 YES
hunspell 1.7.2 YES
hw-probe 1.5 YES
hwdata 0.345 Dependency Error
hwloc 2.9.1 Dependency Error
hybpiper 1.3.1 Skipped
hybrid-lambda develop YES
hybridsim 2.0.1 YES
hydra 4.1.1 YES
hydrogen 1.5.1 Dependency Error
hypar 4.1 Dependency Error
hyperfine 1.17.0 Dependency Error
hyperqueue 0.11.0 Dependency Error
hyperscan v5.2.1 Dependency Error
hyphen 2.8.8 YES
hyphy 2.5.51hf Dependency Error
hypre 2.29.0 YES
hypre-cmake 2.22.0 YES
hztool 4.3.2 Dependency Error
i3 4.14.1 Dependency Error
ibm-databroker 0.7.0 YES
ibm-java None Dependency Error
ibmisc 0.1.0 Dependency Error
icarus 12_0 YES
iceauth 1.0.9 YES
icedtea 3.9.0
icet 2.1.1 YES
ico 1.0.6 YES
icu4c 67.1 YES
id3lib 3.8.3 YES
idba 1.1.3 YES
idg 1.2.0 Dependency Error
idl None Dependency Error
iegenlib 2018-07-03 YES
ignite 2.6.0 YES
igprof 5.9.16 YES
igraph 0.10.6 Dependency Error
igv 2.12.3 YES
igvtools 2.3.98 YES
ike-scan 1.9 YES
ilmbase 2.3.0 YES
ima-evm-utils 1.3.2 YES
imagemagick 7.1.1-11
imake 1.0.9 YES
imath 3.1.9 YES
imgui 1.85 YES
imlib2 1.7.1 YES
imp 2.8.0 Dependency Error
impalajit main YES
improved-rdock main
impute2 2.3.2 YES
infernal 1.1.4 Skipped
influxdb 1.8.1 YES

Page 7 of 38, showing 200 record(s) out of 7,469 total