List of Open Source Software which can be built on Fugaku

Spack logo
Spack will be used to manage open source software packages on Fugaku. Fugaku users can easily use pre-installed packages and built packages based on Spack recipes. The following list shows the results of building/compiling packages for aarch64 according to the Spack recipes. Note that the results in this list do not guarantee that each package will work properly. On the other hand, Fujitsu will provide the following packages compiled with Fujitsu compiler on Fugaku as "external" packages, of which Spack can be aware.
  • OpenJDK 11
  • Ruby 2.6.5 or later
  • Python2 2.7.15
  • Python3 3.6.8
  • Numpy 1.14.3
  • SciPy 1.0.0
  • Eclipse IDE 2019-09 R Packages
Please contact us from email:

Build success rate per compiler


Last Modified: 4/8/24, 2:58 AM GMT
Spack Version: 1/18/24, 1:14 AM GMT
Click each result for further infomation.
Package Version Fujitsu Compiler GCC
3dtk trunk Dependency Error
3proxy 0.8.13 YES
7zip 21.07 Dependency Error
abacus 2.2.3 Dependency Error
abduco 0.6 YES
abi-compliance-checker 2.3 YES
abi-dumper 1.2 YES
abinit 9.8.4 Dependency Error
abseil-cpp 20230125.3 YES
abyss 2.3.5 YES
accfft develop Dependency Error
acct 6.6.4 YES
accumulo 2.0.1 YES
ace 7.1.0 Dependency Error
acfl 23.10 YES
ack 2.22 YES
acl 2.2.53 YES
acpica-tools 20200528 YES
acpid 2.0.28 YES
activeharmony 4.6.0 YES
activemq 5.17.3 YES
acts 30.3.2 Dependency Error
acts-dd4hep 1.0.1 Dependency Error
actsvg 0.4.35 YES
additivefoam 1.0.0 Dependency Error
addrwatch 1.0.2 YES
adept-utils 1.0.1 YES
adf 2017.113 Dependency Error
adiak 0.2.2 YES
adios 1.13.1 YES
adios2 2.9.2 Dependency Error
adlbx 1.0.0 YES
admixtools 7.0.2 Dependency Error
adms 2.3.7 YES
adol-c 2.7.2 YES
advancecomp 2.5 YES
adwaita-icon-theme 3.38.0 Dependency Error
aegean 0.15.2 Dependency Error
aeskeyfind master YES
aespipe 2.4f YES
agile 1.5.1 Dependency Error
agrep 3.41 YES
aida 3.2.1 YES
akantu 3.0.0 YES
alan 2.1.1 YES
albany develop Dependency Error
albert 4.0a_opt4 YES
alembic 1.8.5 YES
alglib 4.00.0 YES
allpaths-lg 52488 Dependency Error
alluxio 2.9.3 YES
alpaka 0.8.0 YES
alpgen 2.1.4 YES
alquimia 1.1.0 Dependency Error
alsa-lib 1.2.3.2 YES
aluminum 1.3.1 YES
amber 20 Dependency Error
amd-aocl 4.1 Dependency Error
amdblis 4.1 Dependency Error
amdfftw 4.1 Skipped
amdlibflame 4.1 Dependency Error
amdlibm 4.1 Dependency Error
amdscalapack 4.1 Dependency Error
amdsmi 5.6.0 Dependency Error
amg2013 1.2 YES
amg2023 cmake-build YES
amgx 2.3.0 Skipped
aml 0.2.1 YES
amp develop Dependency Error
ampl 20220525 Dependency Error
ampliconnoise 1.29 Dependency Error
ampt 2.26-t9b_atlas Dependency Error
amqp-cpp 4.3.24 YES
amr-wind main Dependency Error
amrex 23.11 Dependency Error
amrfinder 3.11.8 Dependency Error
amrvis main Dependency Error
ams 07.25.23-alpha Dependency Error
anaconda2 2019.10 Skipped
anaconda3 2023.09-0 Skipped
andi 0.14 YES
angsd 0.935 YES
anicalculator 1 Dependency Error
ant 1.10.13 YES
antimony 2.8 YES
antlr 2.7.7 YES
ants 20220205 Dependency Error
any2fasta 0.4.2 YES
aocc 4.1.0 Dependency Error
aocl-sparse 4.1 Dependency Error
aocl-utils 4.1 Dependency Error
aoflagger 2.10.0 Dependency Error
aom v1.0.0-errata1 YES
aomp 3.10.0 Dependency Error
apachetop 0.23.2 YES
apcomp 0.0.4 YES
ape 2.2.1 Dependency Error
aperture-photometry 3.0.2 YES
apex 2.6.3 Dependency Error
apfel 3.0.6 YES
apktool 2.7.0 Dependency Error
apple-gl 4.1.0 Dependency Error
apple-glu 1.3.0 Dependency Error
apple-libunwind None Dependency Error
apple-libuuid 1353.100.2 Skipped
applewmproto 1.4.2 YES
appres 1.0.6 YES
apptainer 1.1.9 Dependency Error
apr 1.7.4 YES
apr-util 1.6.3 YES
aragorn 1.2.41 YES
arbor 0.9.0 Dependency Error
arborx 1.4.1 YES
arc 2021-12-01 YES
archer 2.0.0 Dependency Error
argobots 1.1 YES
argon2 20190702 YES
argp-standalone 1.3 Dependency Error
args 6.4.6 YES
argtable 2-13 YES
aria2 1.36.0 Dependency Error
arm-forge 22.1.3 Dependency Error
armadillo 12.4.0 Dependency Error
armcomputelibrary 23.02 Dependency Error
armpl-gcc 23.10_gcc-12.2 Dependency Error
arpack-ng 3.9.0 Dependency Error
arrayfire 3.8.1 Dependency Error
arrow 10.0.1 Dependency Error
asagi 1.0.1 YES
ascent 0.9.2 Dependency Error
asciidoc 9.1.0 YES
asciidoc-py3 9.1.0 YES
asdcplib 2_10_38 YES
asdf-cxx 7.2.1 Dependency Error
asio 1.28.0 YES
aspa master YES
aspcud 1.9.6 Dependency Error
aspect 2.3.0
aspell 0.60.8 Dependency Error
aspell6-de 6-de-20030222-1 Dependency Error
aspell6-en 2017.01.22-0 Dependency Error
aspell6-es 1.11-2 Dependency Error
aspera-cli 3.7.7 YES
assimp 5.3.1 YES
astra 2020-02-03 YES
astral 5.7.1 YES
astyle 3.1 Dependency Error
at-spi2-atk 2.38.0
at-spi2-core 2.48.3
atf 0.21 YES
athena 4.2 Dependency Error
atk 2.38.0
atlas 3.10.3 Dependency Error
atmi 5.5.1 Dependency Error
atom-dft 4.2.6 Dependency Error
atompaw 4.2.0.2 Dependency Error
atop 2.5.0 YES
attr 2.4.48 YES
audacious 4.0.2
audacity 2.4.2
audit-userspace 3.1.1 Dependency Error
augustus 3.5.0 Dependency Error
authd 1.4.4 YES
authselect 1.2.1 YES
autoconf 2.69 Dependency Error
autoconf-archive 2023.02.20 YES
autodiff 1.0.1 YES
autodock-gpu develop Dependency Error
autodock-vina 1.2.3 Dependency Error
autofact 3_4 Dependency Error
autogen 5.18.12 YES
automaded 1.0 Dependency Error
automake 1.16.5 Dependency Error
avizo 2020.1 Dependency Error
aws-ofi-nccl master Dependency Error
aws-ofi-rccl cxi Dependency Error
aws-parallelcluster 2.11.9 YES
aws-sdk-cpp 1.11.144 YES
awscli 1.29.41 YES
awscli-v2 2.13.22 Dependency Error
axel 2.17.10 YES
axl 0.8.0 YES
axom 0.8.1 Dependency Error
azcopy 10.19.0 YES
babelflow 1.1.0 YES
babelstream 4.0 Dependency Error
babeltrace 1.2.4
babl 0.1.106
bacio 2.4.1 YES
backupninja master YES
bam-readcount 1.0.1 Dependency Error
bamaddrg 0.1 YES
bamdst master YES
bamtools 2.5.2 YES
bamutil 1.0.15 Dependency Error
banner 1.3.5 YES
bannergrab master YES
barrnap 0.9 Skipped
bart 0.7.00 Dependency Error
barvinok 0.41.5 YES

Page 1 of 38, showing 200 record(s) out of 7,469 total