List of Open Source Software which can be built on Fugaku

Spack logo
Spack will be used to manage open source software packages on Fugaku. Fugaku users can easily use pre-installed packages and built packages based on Spack recipes. The following list shows the results of building/compiling packages for aarch64 according to the Spack recipes. Note that the results in this list do not guarantee that each package will work properly. On the other hand, Fujitsu will provide the following packages compiled with Fujitsu compiler on Fugaku as "external" packages, of which Spack can be aware.
  • OpenJDK 11
  • Ruby 2.6.5 or later
  • Python2 2.7.15
  • Python3 3.6.8
  • Numpy 1.14.3
  • SciPy 1.0.0
  • Eclipse IDE 2019-09 R Packages
Please contact us from email:

Build success rate per compiler


Last Modified: 4/8/24, 2:58 AM GMT
Spack Version: 1/18/24, 1:14 AM GMT
Click each result for further infomation.
Package Version Fujitsu Compiler GCC
bash 5.2 YES
bash-completion 2.7 YES
bashtop 0.8.17 YES
bat 0.23.0 Dependency Error
batchedblas 1.0 YES
batctl 2019.5 YES
bats 1.10.0 YES
baurmc 1.0 Dependency Error
bazel 6.1.1 Dependency Error
bbcp master YES
bbmap 39.01 YES
bc 1.07.1 YES
bcache 1.0.8 Dependency Error
bcftools 1.16 Dependency Error
bcl2fastq2 2.20.0.422 YES
bdftopcf 1.1 YES
bdii 6.0.1 Dependency Error
bdsim 1.6.0 Dependency Error
bdw-gc 8.2.4 YES
beagle 5.4 YES
beakerlib 1.29.3 YES
bear 3.0.20 Dependency Error
beast-tracer 1.7.2 YES
beast1 1.10.4 Skipped
beast2 2.7.4 Dependency Error
beatnik 1.0 YES
bedops 2.4.41 YES
bedtools2 2.31.0 YES
beforelight 1.0.6 YES
benchmark 1.8.3 YES
berkeley-db 18.1.40 YES
berkeleygw 3.1.0 Dependency Error
bertini 1.5 Dependency Error
bfs 3.0.2 YES
bgpdump master YES
bib2xhtml 3.0-79-ge935 Dependency Error
bigdft-atlab 1.9.2 YES
bigdft-chess 1.9.2 YES
bigdft-core 1.9.2 Dependency Error
bigdft-futile 1.9.2 YES
bigdft-libabinit 1.9.2 YES
bigdft-psolver 1.9.2 YES
bigdft-spred 1.9.2 Dependency Error
bigdft-suite 1.9.2 Dependency Error
bigreqsproto 1.1.2 YES
bind9 9_14_6 YES
binder 1.3.0 YES
binutils 2.41 Dependency Error
bioawk 1.0 YES
biobambam2 2.0.177 Dependency Error
biobloom 2.3.5 Dependency Error
bioconductor-dupradar 1.30.0 Dependency Error
bioconductor-ebseq 1.40.0 YES
bioconductor-rsubread 2.14.2 Dependency Error
bioconductor-tximeta 1.18.1 Dependency Error
biopieces 2016-04-12 Dependency Error
bird 2.0.2 YES
bismark 0.24.1 Dependency Error
bison 3.8.2 YES
bitgroomingz 2022-10-14 YES
bitlbee 3.6-1 Dependency Error
bitmap 1.1.0 YES
bitsery 5.1.0 YES
blackhat 0.9.9 Dependency Error
blaspp 2023.08.25 YES
blast-legacy 2.2.26 Dependency Error
blast-plus 2.14.1 Skipped
blast2go 5.2.5 Dependency Error
blat 37 Dependency Error
blaze 3.8 YES
blis 0.9.0 YES
bliss 0.73 YES
blitz 1.0.2 Dependency Error
blktrace 1.3.0 YES
bloaty 1.1 YES
blogbench 1.2 YES
blt 0.5.3 YES
bmake 20230303 Dependency Error
bmi 2.8.1 YES
bml 2.2.0 YES
bohrium 0.9.1
boinc-client 7.16.5 YES
bolt 2.0 YES
bonniepp 1.98 YES
bookleaf-cpp 2.0.2 YES
boost 1.83.0 YES
boostmplcartesianproduct 20161205 YES
botan 3.2.0 Dependency Error
bowtie 1.3.1 YES
bowtie2 2.5.1 Dependency Error
boxlib 16.12.2 Dependency Error
bpp-core 2.4.1 Dependency Error
bpp-phyl 2.4.1 Dependency Error
bpp-phyl-omics 2.4.1 Dependency Error
bpp-popgen 2.4.1 Dependency Error
bpp-seq 2.4.1 Dependency Error
bpp-seq-omics 2.4.1 Dependency Error
bpp-suite 2.4.1 Dependency Error
bracken 2.8 Dependency Error
brahma 0.0.1 YES
braker 2.1.6 Dependency Error
branson 0.82 YES
breakdancer master Dependency Error
bref3 2019-11-25 YES
breseq 0.38.1 YES
bricks 2023.08.25 Dependency Error
bridger 2014-12-01 Dependency Error
brigand 1.3.0 YES
brltty 6.0 Dependency Error
brotli 1.0.9 YES
brpc 0.9.7 Dependency Error
brunsli 0.1 YES
brynet 1.12.2 YES
bsseeker2 2.1.8 Dependency Error
btop 1.2.13 Dependency Error
bubblewrap 0.8.0 YES
bucky 1.4.4 Dependency Error
buddy 2.4 YES
bueno master YES
bufr 12.0.1 Dependency Error
bulker 0.7.3 Dependency Error
bump2version 1.0.1 YES
bumpversion 0.6.0 YES
busco 5.4.3 Skipped
busybox 1.36.0 Dependency Error
butter 0.3.3 Dependency Error
butterflypack 2.4.0 Dependency Error
bwa 0.7.17 YES
bwtool 1.0 Dependency Error
byacc 20210808 YES
byobu 5.131 YES
byte-unixbench 5.1.3 YES
byteman 4.0.12 YES
bzip2 1.0.8 Dependency Error
c None Skipped
c-ares 1.15.0 YES
c-blosc 1.21.5 YES
c-blosc2 2.11.1 YES
c-lime 2-3-9 YES
c-raft 0.17.1 YES
c3d 1.3.0 Dependency Error
ca-certificates-mozilla 2023-05-30 YES
cabana 0.6.0 YES
cachefilesd 0.10.10 YES
caffe 1.0 Dependency Error
cairo 1.16.0 Dependency Error
cairomm 1.6.4 Dependency Error
caliper 2.10.0 YES
callflow 1.1.2
callpath 1.0.4 Dependency Error
camellia master Dependency Error
camp 2022.10.1 YES
camx 6.50 Dependency Error
canal 1.1.6 YES
candle-benchmarks 0.1 Dependency Error
cans 1.1.4 Dependency Error
cantera 2.5.1 Dependency Error
canu 2.2 Dependency Error
cap3 2015-02-11 YES
capnproto 0.10.2 YES
capstone 4.0.2 YES
cardioid elecfem YES
care 0.3.0 Dependency Error
cargs 1.0.3 YES
casacore 3.5.0 Dependency Error
cask 0.8.1 YES
casper 20220916 Dependency Error
cassandra 4.0.1 YES
catalyst 5.6.0
catch2 3.4.0 YES
cbc 2.10.9 YES
cbench 1.3.0 Dependency Error
cbflib 0.9.2 YES
cblas 2015-06-06 Dependency Error
cbtf 1.9.4.1 YES
cbtf-argonavis 1.9.4.1 Dependency Error
cbtf-argonavis-gui 1.3.0.0 Dependency Error
cbtf-krell 1.9.4.1 Dependency Error
cbtf-lanl 1.9.4.1 Dependency Error
cc65 2.18 YES
ccache 4.8.2
ccfits 2.6 YES
ccls 0.20220729 Dependency Error
ccs-qcd 1.2.1 YES
cctools 7.4.2 Dependency Error
cdbfasta 2017-03-16 YES
cdd 0.61a YES
cddlib 0.94m YES
cdecimal 2.3 Dependency Error
cdhit 4.8.1 YES
cdo 2.2.2 Dependency Error
cdt 1.3.0 YES
ceed 5.0.0 Skipped
celeritas 0.3.2 Dependency Error
cepgen 1.1.0 Dependency Error
cereal 1.3.2 YES
ceres-solver 2.2.0 Dependency Error
cernlib 2022.11.08.0-free Dependency Error
cfitsio 4.3.0 YES
cgal 5.5.2 YES

Page 2 of 38, showing 200 record(s) out of 7,469 total